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Adding New and Existing Graphic Displays

• The Displays folder in the 
Explorer window allows 
users to:

– create new graphic displays

– Add existing displays

– Export/Import Display

• To access, right-click on 
“Displays”

• Graphic displays are 
identified by a .GFX 
extension
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Standard Toolbar

• Provides shortcuts to creating new graphic displays as well 
as performing other application-wide tasks:
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Configuring Graphic Display Settings

• General tab of the Display Settings dialog box allows users 
to define how the graphic display will look during runtime:
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Update rate 
considerations:
• Default rate is 1 s
• For most 

applications, 0.5 s is 
recommended

Replace is the default 
display type. Replace 
displays are full-sized 
displays. They use the 
project window size 
specified in the Project 
Settings editor. (See 
subsequent slides for 
more info)

Click here to adjust the 
displays background color 
and gradient



Replace Display Type

• At runtime, you can have only one Replace display open at 
a time. When the operator opens a Replace display, this is 
what happens:

– The Replace display that was open closes.

– On Top displays that do not use the Cannot Be Replaced option are 
closed.

– The new Replace display opens.

– On Top displays that use the Cannot Be Replaced option remain 
open, on top of the new Replace display.

Note: If the operator attempts to open a Replace display that is already 
open (for example, using a Goto display button to which the same 
display is assigned), the display does not close and FactoryTalk View 
sends an error message to FactoryTalk Diagnostics. 
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On Top Display Type

• Use the On Top option to create pop-up displays that open on top of the 
current Replace display.
– Usually, On Top displays are smaller than Replace displays, so the operator 

does not lose track of display navigation.
• You can open multiple On Top displays.

– If more than one On Top display is open, the display that has focus, or had the 
most recent focus, appears on top.

• When an On Top display closes, the display that had the most recent 
focus appears on top.

• Use the Cannot Be Replaced option if you want the On Top display to 
remain open when a new Replace display is opened.

• On Top displays do not have a Close button in the title bar. Be sure to 
create a close button graphic object in On Top displays so the operator 
can close them.

• The operator cannot move an On Top display by dragging its title bar. 
The runtime position of the display is fixed (according to the position 
settings defined for the display).

• You can specify unique titles for On Top displays. You can use 
embedded variables in the title, and the title text can switch languages 
at runtime.
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Configuring Graphic Display Settings

• Behavior tab of the Display Settings dialog box allows users 
to define how the graphic display will behave at runtime:
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To access Display Settings Dialog Box
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Right-Click in 
inside of 
display and 
select “Display 
Settings…”



FactoryTalk View Studio View Options
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Clicking on any of these items 
Enables/disables their appearance

Open/close toolbars

To test the objects in your displays as you 
work, use the Test Display tool to switch 
to test mode. When you are finished 
testing, switch back to edit mode to 
continue editing.

Enabling a grid and snap provides reliable 
method for lining up graphic objects on 
the display



Workbook Mode
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If you select Workbook Mode from the 
View menu, the workspace shows tabs at 
the bottom for each open editor or 
component.
• Workbook Mode allows you to bring 

forward an open item more quickly 
than by using the Window menu.



Adjusting Display Color & Background
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Click here to adjust the 
displays background color 
and gradient



CREATING GRAPHIC 
OBJECTS
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Graphic Objects

• The elements that make up a graphic display are called 
graphic objects. Use objects to control your process, 
machines, and application. 

• FactoryTalk View comes with a complete range of 
configurable objects such as push buttons, list selectors, 
bar graphs, and trends. 

• FactoryTalk View also comes with drawing objects that you 
can use to illustrate your graphic displays. The drawing 
objects include text, bitmap images, and geometric and 
freehand shapes. 
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Graphic Objects

• Text and graphic objects are 
used to provide operators with 
an accurate representation of 
the machine of process they 
are controlling and Monitoring

• Users can modify items in the 
graphics library or create new 
library files

• Objects menu provides a list of 
available tools.
– The drawing objects submenu is 

used when creating text and 
graphic panels
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Graphic Objects

• The Objects toolbar provides shortcuts to creating basic 
graphic objects:
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Creating Graphic Objects

• To create an object, you must select the object’s 
tool, either by clicking a menu item or by clicking 
the tool on the toolbar. 

• To select a tool 
– Click the tool on the toolbar, or select the tool from the 

Objects menu. When you click a tool, the pointer changes 
to show which tool is active. 

• To deselect a tool, use one of these methods: 
– Double-click an empty area on the display.** 

– Click the Select tool . 

– Click another tool. 
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**For some drawing objects, double-
clicking an empty area of the display 
creates another instance of the object. 
For these objects, to finish drawing, click 
the Select tool. 



Creating Graphic Objects in General

• To create a graphic object 
1. Select the tool for the object to 

create. 
2. Click the mouse where you want 

to position the object, and then 
drag to draw a rectangle the 
general size you want the object 
to be. 

3. Double-click the object to open 
its Properties dialog box. 

4. In the dialog box, specify how the 
object looks, its behavior, and 
connections. 
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Drawing Objects

• Drawing objects are static 
objects used to illustrate your 
graphic displays. Create drawing 
objects on your graphic displays 
to help the operator understand 
how to use the display. 

• All the objects on the Object > 
Drawing menu are (Static) 
drawing objects. 
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Create Text

1. In the Graphics Display editor, select Objects > Drawing > Text or click the icon on the 
toolbar. 

2. Press the mouse button, drag the mouse diagonally to draw the object to the desired 
size, and release the button.

3. The Text Properties dialog box opens. 
4. Enter the text and specify the options. 
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Notes about fonts

• TrueType and OpenType fonts are recommended. These fonts can be resized easily, 
without losing text quality. 

• If you run an application on a computer that does not have the fonts you used when 
setting up the application, Windows substitutes with the fonts that most closely match 
the fonts you specified. 

• If you are going to use the application with multiple languages, use Microsoft Sans 
Serif or Tahoma. These fonts allow for font linking to support the character sets of 
other languages. PanelView Plus 7, PanelView Plus 6, PanelView Plus, PanelView Plus 
Compact, and PanelView Plus CE terminals are shipped with font linking turned on. 
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Creating Images

• Image graphic objects are used to place images on your graphic 
displays.

• You can use images already contained or imported into the Images 
folder, images from the Graphic library files, or use Symbol Factory to 
select and add a graphic to the display and the Images folder.

• For most image objects, an image graphic object is created and then an 
image is linked to it via the Properties dialog box.
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To Create an image object

• To create an image object 
1. In the Graphics Display editor, select 

Objects > Drawing > Image or click the 
image icon on the toolbar. 

2. Press the mouse button, drag the 
mouse diagonally to draw the object to 
the desired size, and release the 
button. The Image Browser opens. 

3. From the Select image list, select the 
image to be shown on the object. 

4. Click OK. 
• The image is placed where you drew the 

rectangle, but the actual size of the 
image is used, rather than the size of the 
rectangle you drew. To change the 
image’s attributes, double-click the 
image to open the Image Properties 
dialog box and specify the options. 
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NOTE: If the image does not appear, try:
• Deleting the image object
• Closing the display
• Reopen the display
• Re-add the image object



Importing Images 

• Individual images files can be imported from the 
following file types:

– Bitmap files (.BMP)

– JPEG files (.JPG)

– AutoCAD files (.DXF)

– Window metafiles (.WMF)

• Use .BMP files whenever possible because the 
files remain a static size at runtime.  Using 
compressed files (such as a .JPG) can result in 
unexpected memory use at runtime.
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Import images into the Images Folder from 
Application Explorer

1. In the Graphics folder, right-click Images and then select Add Component Into 
Application. 

2. In the Files of type box, select the type of image to add. 
3. Navigate to the directory where the .bmp, .png, or .jpg file is stored, and then click 

the file name. Shift-click or Ctrl-click to select additional files. 
4. Click Open to add the selected files to the list in the Images folder. 

© 2008 Swagelok Company. Swagelok confidential.  For internal use only. 



Import images using the Image Browser

• In the Image Browser you can: 
– Import images into the application 

– Select the image to use on a graphic 
object 

– Delete images from the application 

• To open the Image Browser, use 
one of these methods 
– Double-click on Object

– In an object’s Properties dialog box, 
click the Browse button next to the 
Image box.

– Depending on the type of object, the 
Image box could be located on the 
General tab, Label tab, or States tab.

– OR

– With one or more objects selected, in 
the Property Panel, click the Image 
property, and then click the Browse 
button. 
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Graphic Library Objects

• Graphic library files can be accessed from the Application 
Explorer window

• Objects from an open library file can be dragged (or copy and 
pasted) to a graphic display and get placed as an Image 
Graphic Object
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Symbol Factory

• Provides an expanded set 
of graphics

• Graphics are organized 
into categories

• Objects are available as 
line drawings of 
multilayered graphics

• Users can modify stock 
objects

• Custom graphics can be 
added to the Symbol 
Factory
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Add an image from Symbol Factory to a 
graphic object using the image browser:

1. In the graphic display, draw the graphic object you are going 
to import an image for. The Image Browser will open. 

2. In the Image Browser, click Launch Library... Symbol Factory 
will open as a new window. 

3. Browse the Categories frame, click a category to see the 
symbols in the right frame. 

4. Click the graphic to select it for the Graphic Display. 
5. Click Copy, the Symbol Factory minimizes, returning to the 

Image Browser. 
6. Click the Paste from Library button. A dialog box Image 

Name Entry will open. 
7. Type a unique name for the image and click the OK button. 
8. The graphic will now be shown in the Preview window. The 

graphic has been added to the list in the Image Browser. 
This also adds the image to the Images folder in the Explorer 
window. 

9. Click OK to close the Image Browser. The image will be in 
the Graphic Display. 

• Symbol Factory objects imported by the Image Browser will be 
saved in the Images folder as a bitmap. 
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Creating panels

• Use the panel tool to draw 
rectangles and squares that have 
borders.

• You can set up panel objects to 
blink at run time.

• The panel object only supports 
visibility animation. 

To create a panel object 
1. In the Graphics Display editor, 

select Objects > Drawing > 
Panel or click on the toolbar. 

2. Press the mouse button, drag 
the mouse diagonally to draw 
the object to the desired size, 
and release the button. 

• Tip:
– Press Ctrl as you drag the mouse 

to draw a square panel. 
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• To test blinking, click on the 
Blink option, hit Apply & OK.

• Open the Graphics Toolbar 
and press the “Test Display” 
button

• Press the “Edit Display” button 
to return to Edit mode.



Other Graphic Objects

• Arc - Draw an arc (a segment of an ellipse or circle’s perimeter). 
• Ellipse - Draw ellipses and circles. 
• Freehand - Draw freehand shapes as you would with a pen on paper. 
• Line - Draw straight diagonal, horizontal, and vertical lines. 
• Polygon - Draw a series of connected straight lines forming a closed shape. 
• Polyline - Draw a series of connected straight lines. 
• Rectangle - Draw rectangles and squares.. 
• Rounded rectangle - Draw rectangles and squares with rounded corners. 
• Wedge - Draw a filled segment of an ellipse or circle. 
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Use of .wmf and .dxf files

• Windows metafiles (.wmf) and AutoCAD (.dxf) files are 
converted to drawing objects (such as lines, ellipses, and 
polygons) when you import them.
– You can edit the drawing objects the same way you edit 

drawing objects that you create in FactoryTalk View. 
• Depending on the complexity of the metafile or AutoCAD 

file, the converted image could consist of 500 or more 
drawing objects.
– This would lead to long display load times.

– In this case, it would be better to covert the .wmf or .dxf
file to a bitmap, and then show the bitmap in an image 
object. 

To place a .wmf or .dxf file in a display 
1. From the Objects menu, select Import. 
2. Click the mouse where you want to position the file, and then drag 

to draw a rectangle. 
3. In the Files of type box, select the type of file to import. 
4. Navigate to the directory where the file is stored, and then click the 

file to import. 
5. Click Open. 
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MANIPULATING GRAPHIC 
OBJECTS
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Manipulating Graphics Objects

• The Graphics Toolbar, the Arrange Menu and the Objects 
menu all perform specific tasks when manipulating graphic 
objects
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Graphic Objects can be resized by:
• Changing the pixel measurements in the 

object’s Properties dialog box
• Dragging the handles

• Holding Shift while dragging keeps shape 
proportions

• Holding CTRL while dragging forms a perfect 
square

Rotate tool works with all drawing 
objects EXCEPT text, images, 
panels, and rounded rectangles



Manipulating Graphics Objects

• Graphics toolbar provides shortcuts to performing the 
following graphic manipulations:
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Provide uniform distancing 
between two or more objects

Group and Ungroup help combine 
individual graphic objects into a single 
unit (or break a previously grouped 
object into its individual components)

Property Panel and Object Explorer 
provide advanced graphics 
modification and troubleshooting 
techniques



Tools and tips for working with graphic 
objects

• Use the Object Explorer to 
view and select objects. (open 
from Graphics Toolbar)

• Use an object’s Properties 
dialog box to set up the 
object’s properties and assign 
tags and expressions to its 
connections. 

• Use the Property Panel to set 
up individual and group object 
properties, and to assign tags 
and expressions to individual 
objects’ connections. 
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Using Object Explorer

• Object Explorer provides a tree-list 
naming all the objects on the graphic 
display and allows you to select, hide, and 
highlight objects from the list. Groups are 
listed as expandable items in the tree, 
with a + icon. 

• You can use the Object Explorer to: 
– Select an object that is hidden behind other 

objects on the graphic display, without bringing 
the object to the front. Objects are listed in front-
to-back order. The object you created most 
recently is at the front, unless you move it back 
using the Send to Back option. 

– Show or hide an object on the graphic display by 
selecting or clearing the check box in front of the 
object in the Object Explorer. 

– Highlight objects by object type, highlight objects 
that have animation attached, and to highlight 
objects with specific tag or expression 
assignments. 

© 2008 Swagelok Company. Swagelok confidential.  For internal use only. 

• To open Object Explorer
– On the Graphics toolbar, click the icon 

– From the View menu, select Object Explorer

– Right-click an object and select Object Explorer. 



Using Object Explorer
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Properties Dialog Box

• Every graphic object 
has a Properties dialog 
box that you can use to 
set up the object.

• Users can access a 
graphic object’s 
Properties dialog box to 
modify an object’s size, 
color, position on the 
display, and other 
features.

• The options available 
from the dialog box 
change based on the 
graphic object one is 
working with:
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Properties dialog box tabs
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settings



Opening an object’s Properties Dialog Box

• Double-click the object. 
• Right-click the object and select 

Properties. 
• Select the object, and then from 

the Edit menu, select Properties. 
• In the Property Panel, with the 

object selected, click the (Custom) 
property and then click the 
Browse button . 

• In the Property Panel, with the 
object selected, double-click the 
(Custom) property. 

• In the Object Explorer, double-
click the object. 
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Manipulating Graphics Objects

• Property panel 
can be used as 
an alternative to 
an individual 
graphic object’s 
Properties 
dialog box, OR 
it can be used 
to modify 
properties of 
multiple graphic 
objects at the 
same time.
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Manipulating Graphics Objects

• You can create a background for your 
graphic display by converting graphic 
objects to wallpaper.

• When objects are converted to 
wallpaper, they are locked into 
position and become an unchanging 
background for the other objects on 
the display.

• Convert objects that do not need to be 
animated or updated with tag values 
can significantly improve the runtime 
performance of a graphic display.

• Objects that have been converted to 
wallpaper cannot be selected or 
edited until you unlock the wallpaper.

• Also, animations attached to the 
wallpaper objects are not in effect. 
However, animations are restored 
when you unlock the wallpaper.
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Converting graphic objects to wallpaper.

1. Select the object or 
group you want to 
convert to wallpaper.

2. Do one of the 
following:

– Select Edit > Wallpaper > 
Convert to Wallpaper.

– Right-click the selected 
object or group and select 
Convert to Wallpaper.

– To unlock the wallpaper 
objects, right-click any 
empty area of the display 
and select Unlock All 
Wallpaper. Alternatively, 
select Edit > Wallpaper > 
Unlock All Wallpaper.
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